Note: this procedure requires an .img file that you will be required to create from the .iso file you download. TIP: Drag and Drop a file from Finder to Terminal to ‘paste’ the full path without typing and risking type errors (this is in MacOSX).
- Download the desired file (https://help.ubuntu.com/community/Lubuntu/GetLubuntu)
- Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
- Convert the .iso file to .img using the convert option of hdiutil (e.g.,
hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso
) - Note: OS X tends to put the
.dmg
ending on the output file automatically. - Run
diskutil list
to get the current list of devices - Insert your flash media
- Run
diskutil list
again and determine the device node assigned to your flash media (e.g. /dev/disk2) - Run
diskutil unmountDisk /dev/diskN
(replace N with the disk number from the last command; in the previous example, N would be 2) - Execute
sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m
(replace/path/to/downloaded.img
with the path where the image file is located; for example,./lubuntu.img
or./lubuntu.dmg
). - Using
/dev/rdisk
instead of/dev/disk
may be faster.
If you see the errordd: Invalid number '1m'
, you are using GNU dd. Use the same command but replacebs=1m
withbs=1M
.
If you see the errordd: /dev/diskN: Resource busy
, make sure the disk is not in use. Start the ‘Disk Utility.app’ and unmount (don’t eject) the drive. - Run
diskutil eject /dev/diskN
and remove your flash media when the command completes - Done
Unetbootin seems rather good but doesnt work in this instance. (http://unetbootin.sourceforge.net/ )
Reference from : http://www.ubuntu.com/download/ubuntu/download